BREAKING

0

Παλαιότερα Android apps ενδεχομένως να σταματήσουν να λειτουργούν στο Android P

Ένα νέο class ανακαλύφθηκε στην τελευταία developer preview του Android P που θέτει μια minimum API έκδοση. Αν μια τέτοια απαίτηση δεν την ικανοποιούν οι εφαρμογές, θα αρχίσει να εμφανίζεται το εξής μήνυμα: Αυτό το app έχει δημιουργηθεί για μια παλαιότερη έκδοση του Android και ίσως δε λειτουργεί σωστά. Ελέγξτε για ενημερώσεις ή επικοινωνήστε με τον developer.

android-p

Η ελάχιστη API έκδοση για το Android P είναι 17 ( 4.2 Jelly Bean). Ακόμη όμως δε γνωρίζουμε αν ένας τέτοιος περιορισμός θα παραμείνει στην τελική έκδοση του Android P ή τα apps θα σταματούν να λειτουργούν. Η Google έχει ήδη δείξει την αφοσίωσή της να ενημερώσει Play Store apps, θέτοντας ένα minimum API για όλα τα νέα apps που θα ανεβαίνουν στο Play Store. Με αυτόν τον τρόπο, όλα τα νέα apps που γίνονται submitted στο Play Store θα μπορούν να λειτουργούν με τις τελευταίες και πιο πρόσφατες εκδόσεις του Android, ενώ όσες εφαρμογές δεν ενημερωθούν, ίσως σταματήσουν να λειτουργούν.

Και η Apple όμως έχει κάνει ένα παρόμοιο πράγμα, ξεκαθαρίζοντας το App Store από τα παλαιότερα apps και αν προσπαθήσεις να τρέξεις ένα τέτοιο app από το iCloud backup, είτε θα δεις ένα αναδυόμενο μήνυμα προειδοποίησης, είτε δεν θα μπορείς να το τρέξεις καθόλου.

0 Comment